FT-890's PA is always on and running HOT

Discuss anything related to any of the Classic Yaesu Transceivers

Moderators: KE7GUY, KC9FOZ, EA5/G0KOM, KG6JEV

FT-890's PA is always on and running HOT

Postby N0NB » Fri Jun 08, 2018 6:44 pm

This is my first post in the forum. Thanks for reading.

I am looking at a friend's '890 and discovered that that the top panel above the heatsink is very warm. A quick Google search found someone else with the same problem and most suggestions were to measure the current on receive. I did so and after watching it for a good while it had run up to about 2.9 Amps. The factory spec is 1.5 Amps.

I opened it up and checked the PA idling current per the technical manual and measuring between TP40001 and TP4002 it was running around 9.8 mv when it should be around 6 mV. I spent some time adjusting it to be around 6 mV at its warmest, so I put it back together and measured the receive current and it was around 2.28 Amps once warmed up. That is quite a bit less, but still about 700 mA more than spec.

I spent some time tracing things around the PA (100W version) and have come to assume the PA is fine as the T9 line coming from the Local Unit is resting at 1.3V on receive when it should be 0V per the schematic. On TX it rises to the nominal 8.8V shown on the PA schematic. As I understand it, this is keeping Q4009 on and activating the PA for transmit mode. Other voltages I measured around the PA are consistent with the TX values on the schematic.

The T9 line seems to be sourced from several places on the Local Unit. What might be the likely culprit? The 1.3V on the T9 line at the PA unit is constant regardless of mode selected.

I am working from a scanned copy of the Technical Manual on my computer and the resolution becomes poor as I zoom in, especially for the Local unit schematic.
N0NB
 
Posts: 2
Joined: Thu Jun 07, 2018 11:46 pm

Re: FT-890's PA is always on and running HOT

Postby N8YX » Mon Jun 11, 2018 3:20 pm

What happens when you disconnect the T9 line from the PA?
N8YX
 
Posts: 41
Joined: Thu Aug 03, 2006 12:47 pm

Re: FT-890's PA is always on and running HOT

Postby N0NB » Tue Jun 12, 2018 5:38 pm

The rest of the radio goes dead as it's on a header with several other lines, one of which is the 13+ VDC line to the rest. I don't have a pin extractor to remove just that lead.
N0NB
 
Posts: 2
Joined: Thu Jun 07, 2018 11:46 pm


Return to HF Transceivers

Who is online

Users browsing this forum: No registered users and 3 guests

cron